Premium Membership - All Voxengo Plugins at a Fixed One-Time Fee - Click Here For More Info
Forums     Plugins     Redunoise Sonar4 - Track Freeze gives Out of Memory Error





Hi Aleksey,

Trying to do a track freeze in Sonar4 (WDM - maudio delta drivers) I get a 'Out of Memory' error when I attempt to do track freeze and the latency is set to 1.5ms in Sonar4.  If I put the latency to 7.3ms I can freeze the track again but anything less gives me the error.

I am using Redunoise 1.3 - also I have never tried latency at 1.5ms with Redunoise in Sonar4 untill now.  Usually I have it at about 100ms but changed it because of another new plugin I'm trying out.

What do you think?

Do you see it in the context of 'Exception', or it just shows 'Out of Memory'?  I.e. could you describe the error window you are getting?

No - it's not an exception.  It just looks like a Sonar error window.

Sonar doesn't crash or go away or anything bad.  The message occurs right near the threhold of not playing though, if I drop the latency a slight bit further then Sonar won't playback.

Like I mentioned I haven't run my latency that low in the past so I don't know if it's a new thing because of v1.3 or not.

Does this error comes only when you load Redunoise?  Which actions produce this error?  Could you try this with other Voxengo plug-ins?

OK - back again (lots of stuff happening for me in audio right now!).

I have Sonar4 set with a 5.4ms latency and successfully froze a track.  Now I insert Redunoise and notice the track won't play (I saw this before too), there are no error messages yet.  Try to freeze the track and I get an error box with:

Sonar4 Producer Edition

Mixdown Aborted.

Ran Out of Memory

Task manager says I have 618MB of free memory...

As far as other Voxengo plugs doing this I haven't seen any others do it yet.  I loaded up Pristine Space with 8 channels of impulses and no problem there.

I then put enough Elephants and Soniformers on the track until playback gave me the dropout indicator and playback was basically doomed.  Sonar did try to playback but after about 200ms a dropout occured.  In this condition I was able to successfully use freeze.

Please switch Pristine Space to 32768 latency and try this again.  Probably there is a problem with large Redunoise's latency coupled with freeze function.

Bad news - I lost it and it looks like I failed to take note of a variable cause I can't recreate this either in the original project or in a new one...

I tried Pristine Space with the 32K latency and it's fine but so is Redunoise now.  Also I can't get Sonar4 back to a 5.4ms latency anymore even if adjusting the sample buffer on the audiophile2496.  I can only go to 5.8ms or other settings but not 5.4ms anymore...argh

I'll report back if I can get it again.


I accidently stumbled into this on the Cakewalk website in the knowledge base for Sonar4:


Out of Memory Error

The information in this article applies to:

SONAR 4 Producer Edition

SONAR 4 Studio Edition

SONAR 3 Producer Edition

SONAR 3 Studio Edition



This error is typically received when attempting to apply an effect.  This issue is caused when Windows registry information regarding a specific effect gets corrupted.

Reinstalling the effect should resolve the issue.

This issue can sometimes occur when video resources are low.

Close any extra views which are open and shut off any programs running in the background.  In the case of a resource leak, you should update your video card drivers, as well.


That does not really tell much about the cause of this problem.  Kyle, also please make sure you are using the latest Redunoise v1.3 as it implements various 'invisible' but useful fixes.
This topic was last updated 180 days ago, and thus it was archived.  Replying is disabled for this topic.