Premium Membership - All Voxengo Plugins at a Fixed One-Time Fee - Click Here For More Info
Forums     Discussions     Free Audio Plugins Bug Report - OldSkoolVerb V2.3.





Hey Guys,

I recently updated my OldSkoolVerb Plugin to the latest Version (V2.3.).

Since then i have noticed a severe Bug.

It happens 50% of the time when i open a plugin instance.

i load a oldskoolverb instance and a loud transient plop happens. the bus meter go into red for a short moment. this happens as well when i start playback and stopp playback. my hdspe mixer goes into red, too. when i close logic and open the project again the problem most likely stopps and i can work again.... or not :-).

the problem also occurs when i copy and paste a oldskoolverb instance to another bus.

Any suggestions?  OldSkoolVerb is really a essential part of my tools.  I love it.  After the update i love it even more, but this bug is really killing my work fun and maybe my speakers ;-).

All the Best


Sorry for the issue.  Are you sure this problem is caused exactly by OldSkoolVerb?  Can you reproduce this problem inside a new empty project, without any other plugins loaded?

Why I'm asking this is because I have not received any similar reports in the last 6 months since OldSkoolVerb 2.3 release.

Also, which audio card block size/latency are you using?

Hallo Aleksey,

Thanks for your response.  I'm sure that my problem is caused by OldSkoolVerb.  Everytime i remove the plugin from the session and open the session again the problem is gone. i verified this a couple of times.

the problem occured right after updating to V2.3. a week ago.

i run LogicPro 9 on a MacPro 8-core.  OSX 10.6.8

On my MBP with OSX 10.6.8. its the same problem. i use my MBP for recording with a M-Audio Profire.

i'm using a RME PCIe Express Card with a Multiface together with my MacPro.

I/O Buffer is 1024 samples.

unfortunately i have to run my DAW in 32 bit, because i have too many cool plugins which are still 32 bit.

i hope we can solve it.

all the best


Thanks for the info.  Removing plugin and reloading the project can't be used as a definite proof.  Have you tried to simply reload the project without removing OldSkoolVerb?  If it works just by reloading it may not be OldSkoolVerb's issue.

Meanwhile I've scanned through changes made in the code, there were almost no changes introduced between OldSkoolVerb v2.2 and v2.3.  As a solution you can simply use v2.2.  However, I think this won't solve the problem.

Also please tell me if this problem happens in a completely new project, without other plugins in it - this is important.

Hey Aleksey,

I didn't upgrade from 2.2. it was an old version 1.X. don't know exactly.

I made two tests.

Test 1:

- Created new project (empty)

- created a stereo track with Sonimus Satson Channel Plugin

- put Sonimus Satson Bus Plugin on Master Bus

- put a Drum Loop an Sterea Track

- Created a Bussend with Send Level 0,0 dB to Bus 1

- Bus Channel 1 had Satson Bus Plugin in the first slot and the Voxengo OldSkoolVerb on the second slot

Result Test1: After doing all this everything worked fine, but when i closed the project and reloaded the project the problem like described occured.

please see the screenshots:

Screenshot Logic after Closing and Opening the project:

Screenshot of my RME Mixer at the same time:

Igrnoring the problem an trying to start playback resuts in no audio coming through the master bus:

one thing is very interesting. when i remove the Sonimus Satson Bus Plugin from the Master Bus.  Audio playback works again.

Test 2:

- Created new project (empty)

- created a stereo track (no plugins)

- put a Drum Loop on the Stereo Track

- Created a Busssend with Send Level 0,0 dB to Bus 1

- Bus Channel 1 had Voxengo OldSkoolVerb on the first slot

- this time Voxengo OldSkoolVerb is the only plugin in the session

Result Test2: After doing all this everything worked fine, but when i closed the project and reloaded the project the problem occured a little bit different. i had a ugly highly distorted sound coming out of the Left side of the Bus Channel.  I was not a short peak signal. it was a permanent sound which stopped when i closed the session.

please see the screenshot:

I hope all this can help you.

usualy when i close the session and reopen it a few times i can work, but it shuldn't be like this.


When doing exactly Test2 I cannot reproduce this issue - I use Mac OS X 10.7.5 and Logic 9.1.8.

I suggest you to try Test2 with a different sound, not a drum loop but maybe some soundtrack.  I also suggest you to reload Logic completely so that there are no leftovers from plugins from other sessions.

ah ok what you mean with soundtrack?

ah instrument track i recorded?? or maybe a song?

Yes, a song or stereo instrument track - maybe this bug happens with some sound files only.
This topic was last updated 180 days ago, and thus it was archived.  Replying is disabled for this topic.