Premium Membership - All Voxengo Plugins at a Fixed One-Time Fee - Click Here For More Info
Forums     Plugins     Elephant Can't get Elephant V2 registered on Win 8 64 bit (solved)

I realize that Elephant V2 has been replaced by Elephant V3 and I do own V3 and it works well.

However, I still like using V2 in clip mode on drums such as snare, kick. and tom subgroup.  The V2 footprint is smaller and I prefer the metering for clipping.  It's easy to see when the clipping threshold has been reached.

The problem is that it won't register on my Win 8 64 bit, Sonar X2 64 bit system.  It runs in demo mode and won't accept the registration.  It looks like it registers, no errors reported, but the plug-in remains "unregistered" when clicking on the question mark.  I tried admin mode and I tried uninstalling and reinstalling but no good.

Should I be able to register it on Win 8 64 bit or is this the end of life for Elephant V2?

Thank You.

Please run the "Register" shortcut with the administrator rights - this can be done by right-clicking on the shortcut.

I tried administrator rights and it still did not register.

What I did was to pin the "Register Elephant" tile from the Windows 8 "Start Menu" to the taskbar.  Now I could access "Register Elephant" from the desktop so I was able to run it from there and the registration was sucessful.

After registration I unpinned it from the taskbar -- no need to keep it there once registered.

Hope this helps someone else should they find this same Windows 8 anomaly.

Thanks for the tip.

Ok, I had to go through this too, with a set of four earlier plug-ins moved to Win8.

The key to it is what Aleksey says: you have to explicitly use right-mouse-run-as-administrator to get the registering application to operate correctly.

The advice about 'pinning to Start Menu' is not easy to interpret on Win8, until you realize the pages of apps offered from Winkey-q are the new Start menu in its eyes.

Thus pinning to it, means you can find the app there, and conveniently right-mouse, so that the option to start as administrator comes at the bottom of the screen.

Anyway, I got Elephant, Gliss EQ, Transmodder, and Crunchessor, all at version 2.x, to properly register and show so, also operate without issues, using Audition CS6.

Happy with this, as they are my old friends ;)

This topic was last updated 180 days ago, and thus it was archived.  Replying is disabled for this topic.