Premium Membership - All Voxengo Plugins at a Fixed One-Time Fee - Click Here For More Info
Forums     Plugins     Drumformer Fails scan in SONAR X1 and WaveLab 7

I'm trying to evaluate your new channel strip (which apparently took precedence over getting CurveEQ out the door on the new platform).  So far, I have been unable to find a host that will recognize it.  In SONAR, the only thing that shows up in the registry is an entry in the SONAR VST inventory that has two keys.  One is isVst=0 and the other is touch=1.

How do I get around this?

It works in Sonar X1 for me.  I haven't done anything special on my end.

dantarbill: How do I get around this?

Please make sure you've downloaded the correct version - 32 or 64 bit, depending on your host's bit'ness.

I tried it on my laptop.  It scans properly and works there.  So I tried exporting the registry settings for the plugin and importing them into the desktop system that's having the issue.  It now shows up in SONAR and I can instantiate it in an FX bin, but it gets errors when I try to open it.

I've had other problems with this machine that indicate that it's "not quite right", but I'm not sure what software components are out of whack.  Is there some library function (probably particularly graphics) that you're using in Drumformer that you haven't yet used in your other plugs.  If so, what library or package does it belong to? (Maybe we can figure out what needs to be refreshed or updated on MY end.)

(Both systems are Windows XP with all the latest service packs.  The failing system is an AMD Athlon 64 single core.)

It's because of Athlon 64 for sure - it's too much outdated.  The plug-in requires SSE2 capable-processor.  SSE2 brings about 10% performance boost in comparison to non-SSE2 binary, just by enabling it in the compiler.

We have made an announcement about this route change:

Unfortunately, we won't go back since it's not for the benefit of a lot of users while carrying two versions, SSE2 and non-SSE2, is confusing to the users too much (too technical to understand the difference for many).

I thought it might end up being *something* like that. (Actually, before I read your answer, it struck me that it might be *exactly* that.) It may well be that lack of SSE2 instructions is also why the new tool HUD in SONAR X1 refuses to work on this system.  In a left handed way, this is good news.  It means I have one more sales point to bring to the "financial committee" that authorizes expenditures on new studio systems.

"Doesn't work at all" is a lot stronger argument than "works very poorly".

Yes, that sounds like a good reason to upgrade.  I think soon there will be more SSE2-only software released, on a global scale.

That may well *not* be the problem...

The AMD Athlon 64 3400+ 2.2 GHz processor in question is listed as supporting I guess I'm back to my question about third party runtime components.

We do not use third-party DLL components, only Windows API, not beyond functionality offered by Windows XP SP3.

I still think it may be some incompatibility of Athlon 64 instruction set.

A follow up - I've noticed that I was mistakenly using SSE3 compilation flag like the one I'm using for 64-bit code compilation.  The next update to Drumformer should work on your system as well.  I'm sorry for the confusion.
This topic was last updated 180 days ago, and thus it was archived.  Replying is disabled for this topic.