Premium Membership - All Voxengo Plugins at a Fixed One-Time Fee - Click Here For More Info
Forums     Plugins     CurveEQ BETA testing v1.7

This topic was created before release of the latest product version, and it may contain details irrelevant to this version.  Replying is disabled for this topic.

Everyone is invited to test the new beta of v1.7 release:

Comments and suggestions are welcomed.

Here's excerpt from "what's new" info file:

1.  Several minor bugfixes.

2.  Performance of EQ engine was improved by at least 70%.  This means one can run 70% more EQ plug-ins in the same project now.  This allows to use CurveEQ plug-ins seamlessly even in audio track inserts.

3.  New 16 exclusively-captured gear options added.

4.  Gear option list was upgraded to a scrolling list with arrows.

5. "/" and "*" labels on buttons were changed to arrows.

6.  IMPORTANT ADDITION.  Now it is possible to enable saturator's latency buffering.  It can be enabled or disabled in "?" screen.  Please, note that when this feature is enabled plug-in will issue additional 4500 samples of latency while allowing host application to correctly buffer saturator's latency.  If your host does not buffer plug-in latency at all, there is no reason in enabling saturator's latency buffering.  Also, when this buffering is enabled, plug-in will consume slightly more CPU power.  Saturator's latency buffering works only with sample rates up to 192 kHz.

7.  Help file updated.

8.  Added "pre gain" control which is showed on the control surface in the form of a horizontal dashed line.  This control is useful when saturator is enabled.  To get this control visible 0 dB baseline must be dragged first.  Please, note that dashed line snaps to 0 dB baseline if moved near.

Two whole days and no bug reports...  Can I guess it is OK and almost ready for release? :)

Hi Aleksey,

sorry, it's me again (i'm looking like problem demo user :-)

I tried to use plugin with Directixer 2.3 (VST2DX converter), because Samplitude, doesn't support VST plugins at object level (only tracks and master section) and i found probably bug.

Access violation at adress 04353F79 in module "VoxengoCu...dll".  Read of address 00000788. dialog box with [OK] button as usual.

appears every initialisation of plugin's GUI(first load, every reopening for params. change).  I think it's only some problem of graphics because audio appears to be working as normal.

same situation is when i try to use FXPansion VST to DirectX Adaptor (3.01, magix relase, bundled with samplitude 6).  If i use plugin in native VST, everything is fine.  I tested it on two different computers(both have XP)

...previous 1.7d subrelase which you sent me was also O.K.



OK, Netopeer.  Actually, it is good you found this bug.  I will contact you via e-mail as soon as I find its cause.

Thanks for care,


I have uploaded a newer version which may have this bug fixed:

Hello Aleksey,

unfortunatelly, problem still preserves in subversion 1.7h.

I try to found where is source of problem.... you use some external runtime dlls? (maybe some version conflict???)

...what changes was introduced after 1.7d (this version was fine)?

...both vst2dx adaptors, which i tried has some additional controls(fixed size buffers, alternative gui draw method), i tried several combinations, but it maybe needs some tweaking.

If you want some additional info, feel free to contact me.

thank you


Here's a yet another version:  I have discovered an actual bug (not an incompatibility), so maybe it will work again now.  And yes, I have made some additions in these latest betas which worked fine on my setup.

This topic was created before release of the latest product version, and it may contain details irrelevant to this version.  Replying is disabled for this topic.