Premium Membership - All Voxengo Plugins at a Fixed One-Time Fee - Click Here For More Info
Forums     Plugins     CurveEQ CurveEQ and cpu useage

This topic was created before release of the latest product version, and it may contain details irrelevant to this version.  Replying is disabled for this topic.

Hello,

Last night I was attempting to mix down an audio track (in Samplitude) with CurveEQ.  My cpu meter told me that the one track + CurveEQ was giving me cpu 80-90% useage.  This seems very high.  I was unable to complete a mixdown without audio dropouts.  I had already mixed down this track with Soniformer and Redunoise without problems.  I have a P4 1.6GHz + 1gb ram.  Echo Mia audio card using wdm drivers (Samplitude Studio 6 does not include ASIO drivers).  Typically my system runs very well and handles lots of fx/vsti/etc.

thanks

sluggo


Which version CurveEQ are you using now (this can be looked up in the bottom right corner of the GUI)?

Since CurveEQ naturally uses more than 10x times less CPU resources than Redunoise I wonder what kind of issue is that.  Can you try replacing CurveEQ for a moment with either Redunoise, Elephant or Soniformer?


I'm using v2.0a

Today when I opened the track my cpu useage is much lower, probably what it should be (8%).  However, bouncing (or just playback) creates constant audio dropouts.  Replacing the curveEQ with soniformer and playback is fine again.  Please note that I am using CurveEQ wrapped in Samplitude 6.05 which only supports DX plugins, not vst.

thanks

sluggo


To get rid of dropouts you should use larger audiocard latency.  You can also try to enable the new 'Spread CPU load' option (available in '?' dialog).

I don't think this is an issue of audiocard latency.  I've tried usng 2048 samples and 4096 samples, and I've tried enabling and disabling "spread cpu load".  I usually use 512 samples without problems.

I cannot confirm whether my "dropouts" are similar to the type of dropouts that I've read about when people's audiocard latency is too small.  I've never had dropouts before.

Please also note that I have not had any problems using Soniformer or Redunoise (which uses upto 70% of my cpu).

thanks


Please, send me preset you are using with CurveEQ when it gives problems: support@voxengo.com

Please also state which Samplitude version you are using.

Could you try to uninstall v2.0a beta in install the v1.9?  Possibly, that was something introduced in the beta version.  BTW, this is pretty important to check v1.9 whether it works or not.  So far, I have not heard about such problem from the existing user (including those using Samplitude).

Thanks!


Hello Aleksey,

I've tried this with several (factory) presets and they all seem the same in terms of dropouts.  Interestingly, once I start playback, the first dropout always appears 25s later.

I tried this with 1.9 with the same results.  I'm using Samplitude Studio 6.05.  I changed Samplitude's internal buffers and this did not affect the outcome.  As well, I changed the audiocard latency and this did not change the outcome.  The first dropout is always 25s after starting playback, no matter where in the recording I start playback from.


Wait, have you registered your copy?  There is a special 'Register CurveEQ' program.  You should provide your registration number there.  After 25 seconds unregistered plug-in issues a demo-mode drop-out.

However, this has nothing to do with the 80-90% CPU load.  So, are you getting a CPU overload or pause in audio? ('dropout' can be applied to both).


I think I remember reading somewhere that earlier versions of Samplitude have a memory problem, and don't always release resources back to the system after unloading plugs.

Do you have the latest version?  If not, I'd recommend checking the updates list at magix just to make sure.  There were some nasty little issues from time to time.

This topic was created before release of the latest product version, and it may contain details irrelevant to this version.  Replying is disabled for this topic.