Voxengo Premium Membership - All Voxengo Plugins For a Fixed One-Time Fee
Forums     Plugins     Voxformer High CPU drain when GUI open


Last

Next

Previous

First



Hi Aleksey,

I find myself with no complaints generally about your plugins, my only issue is something which popped up recently: I have been forced to 64bit Live to cope with the project size, and with this I have noticed the Voxengo plugins are taking a lot more CPU than they did on my 32bit version.

I can perform a simple test:

- empty Live project, dump audio file on audio channel

- drop in Voxformer on audio channel

- open GUI

- loop audio file and press play

- with the GUI open I have CPU hits of around 40-50% on an i5 3.5 16GB OSX

- close the GUI and CPU drops to a reasonable 5%

If you need any more data to prove this, please let me know and I will do my best to capture it.

Please consider this a problem, with all 64bit GUIs you sell - I only create awareness here as it my most used plugin.

I look forward to hearing your analysis of the problem.

Many thanks,

Matthew


Which version of Voxformer and Live are you using?

Also, which OSX version?

Voxformer 2.9

OSX 10.11.1

Live 9.5

thanks


Also, I received no email alert from this thread even though I have the 'Notify via email' flag ticked.

Update to recreate:

- empty project - cpu 3%

- load voxformer on audio channel (GUI automatically opens)

- cpu hits 35%


Could you try the latest Live 9.6 64-bit?  I cannot seem to be able to reproduce the issue, but I'm testing in OS X 10.10.

sure - just tried with the newest 9.6, high CPU still there

Do you happen to have some other host audio application where you can try Voxformer?

The only other VST host I have is Plogue Bidule, and a quick test in there doesn't reveal the same CPU issue - it seems to behave ok.

I haven't tested AU - if I get a bit of time this afternoon, I will.

This topic was last updated 180 days ago, and thus it was archived.  Replying is disabled for this topic.

Last

Next

Previous

First