Voxengo Premium Membership - All Voxengo Plugins For a Fixed One-Time Fee
Forums     Plugins     r8brain PRO Min Phase troubles in r8BrainPro


Hi -

I can't seem to use MP mode on r8BrainPro when downsampling from 48k to 44.1k due to clipping.  I apply limiting prior to capturing files at 48k/32bit.  The ceiling on the limiter is set to -0.5 and yet I still get intersample peaks over 0.0dBFs after SRC.  I have r8B set to MP and Ultra-steep mode is ON.

Levels remain in check when I use LP mode but I don't like the sound of it compared to MP; LP sounds plasticy by comparison.

Any suggestions...?

Thanks.


This is an expected behavior, and it is described in the user's manual.  It is suggested to apply peak limiting AFTER conversion, not before it.  Beside that you'll also need to use 'prevent clipping' option in r8brain PRO.

Aleksey Vaneev:It is suggested to apply peak limiting AFTER conversion, not before it.  Beside that you'll also need to use 'prevent clipping' option in r8brain PRO.

SRC before limiting does not sound as good IMO.  I like the more open, transparent sound of limiting first and then performing SRC.

With all due respect, all 'Prevent clipping' does is add normalization to the file which brings the entire program level down according to the amplitude of these intersample peaks.  Not the solution I'm looking for here.  I would like the bulk of the (unclipped) material to remain intact as processed and figure out a way to handle the few peaks that are slipping thru causing the overs.

For this project, I went ahead and used MinPhase and went back and re-drew the offending peaks (only a sample or 2 in duration I might add) so that the rest of the material was not affected.  I much prefer the outcome from doing it this way than what I got when applying limiting after SRC.

Is it not possible to include some sort of algorithm into r8B that would correct these ISPs other than dropping the entire program level?  Perhaps that is a job for the limiter instead...?

Thanks for the reply.


You may also apply additional limiting after using r8brain PRO with 'prevent clipping' option: this way you can bring level back while reducing offending peaks.  I do not think this should be implemented in r8brain PRO: it won't do it better than the limiter of your choice.

This is because MP is the equivalent of going DAC/ADC through reference quality converters as opposed to the pure digital mode of LP.

I also far prefer MP.  It's warmer, and much more pleasing.

Your problem, therefore, is over limiting and/or overcompression in the original mix.

To get ISP you are clipping the outputs of the DAC stage, so the obvious answer is to reduce the amount of limiting going on.  The sound will be better for it - honestly.

Overcompression & excessive limiting are modern curses IMHO.

Perhaps not the answer you're looking for - but it is the honest one.

www.opusproductions.com

Multichannel Audio Specialists

DVD-A, DVD-V Authoring

Mixing & Mastering to most formats

This topic was last updated 180 days ago, and thus it was archived.  Replying is disabled for this topic.