Voxengo Premium Membership - All Voxengo Plugins For a Fixed One-Time Fee
Forums     Plugins     Pristine Space Why the CPU spikes?


When running Nuendo 2 and trying out Pristine Space, with longer impulses, the CPU performance meter goes from about 30% to 70%, spiking, a couple times every second.  Up/down, up/down, etc.  This causes the audio to flutter.

Not to bad mouth Voxengo, but I tried the same impulses with the free SIR plug in, and it played back flawlessly without the CPU spikes.

Are there some settings I'm missing with Pristine Space?  I set the input/output to 2, and latency is at 2048.

I'm running on a PC with a 3.0 GHz Pentium 4 and 1 Gig memory.  I don't think its a system issue, as SIR works fine.


Have you tried increasing audiocard latency?  It's the only way to lower stuttering.  Also make sure you are not using the 'zero latency' mode as it can give such uneven CPU loads.

BTW, how long is the impulse you are loading into Pristine Space and SIR?

This is an old topic but I'll reply here as the issue is the same.  With Multi Processing enabled in SX3 the CPU spikes constantly.  Without the Multi Processing the action is more stable even if PS can still cause the CPU to overload even from 65% processor load.  I'm not sure if the Multi Processing is necessary but is there anything to cure the spiking with the Multi Processing on?

edit: I checked with a huge Cubase project and the Multi Processing has an effect of 7 percent or so.  Without Multi Processing there isn't enough CPU power and with the Multi Processing Pristine Space causes the spikes.  What to do?


The only stable cure for spikes with Pristine Space is to increase audio card latency to as high value as possible - in parallel, increasing Pristine Space's latency would be beneficial, too.  Make sure you are not using the 'zero latency' mode as well - it may cause much CPU spiking.
This topic was last updated 180 days ago, and thus it was archived.  Replying is disabled for this topic.