Voxengo Premium Membership - All Voxengo Plugins For a Fixed One-Time Fee
Forums     Plugins     Pristine Space Cannot get Pristine to work.


Hi,

Are there any known issues with users of Prisitne in Sonar 3?  I can get it to work without any fuss at all in Project 5 but it just will not work in Sonar.

I have not changed any settings and will gladly listen to suggestions.


How does this 'not working' shows itself, step-by-step please?  Does Pristine Space load in Sonar3?

Just done some more testing...sorry if I did not provide enough information it does now work but not at a latency below 20 milliseconds, is this normal?

It does load in Sonar 3 but with either WDM or ASIO drivers the latency setting must be above 20 ms, why is this?


On some system configurations a really low latency processing is not possible with convolution reverbs, because convolution simply needs a great amount of CPU resources.

By the way, you've stated you have not adjusted any settings of Pristine Space.  For the case of low audiocard latency I suggest you to adjust Pristine Space's internal latency also (the necessary setting will be available when you press '?' on the UI screen).  You may set PS's latency to any value below 512.


Thanks for the response Aleksey I will try this.  Great program by the way.

Hi Aleksey -- I've just tested this in SONAR, and I can confirm that you can't go below 23ms using PS -- I'd never noticed this before because I generally work at high latencies.  CPU usage was not even that high.  On the SONAR forum cmusicmaker posted that he can get much lower using Traktion -- could this be a SONAR issue or a PS issue?

If PS works seamlessly in Tracktion at low latencies, it is highly probable that Sonar's audio engine is too sensitive towards audio processing code overloads (not really overloads, but uneven CPU loads).

In fact, I always had a feeling that Sonar2.2 is very sensitive in this respect.


There is a solution to this problem -- in one of SONAR's initialisation files -- aud.ini -- is a parameter called ExtraPluginBufs.  This needs to be set to equal something like 128, 256 or 512.

Nice to know that this can be resolved!

Here is another workaround...

Adjusting latency settings in your sound card to 256 and Pristine’s to 64.  I have found with this setting that Sonar3 can work at 5.8 milliseconds with Prisitine Space.

I have not tried lower than 5.8ms but in theory it should be possible!

This topic was last updated 180 days ago, and thus it was archived.  Replying is disabled for this topic.