Voxengo Premium Membership - All Voxengo Plugins For a Fixed One-Time Fee
Forums     Plugins     Marquis Compressor Dry Knob, why does this happen ? Is it a bug ?

This topic was created before release of the latest product version, and it may contain details irrelevant to this version.  Replying is disabled for this topic.

hi Aleksey, I have noticed something with the Marquis compressor which prevents me from using the Dry Knob.  When I am using very hard compression settings, as soon as I bring up the Dry knob, the output gets EXTREMELY loud.  When sitting at around 50% it is the loudest and at 0% and 100% the output is EXTREMELY soft.

Try some seriously hard compression, threshold -40 db, ratio 50:1 and you'll see it immediately.

WARNING: Put a limiter after it or you'll blow your speakers ! :D

Any idea why this happens ?  I find the behaviour very confusing.  OH and by the way, this is the finest compresssor I have heard in native VST land, and I have heard ALL of them ! :D

Cheers

Fots


This behavior is to be expected.  If you do not want it you can disable the 'Makeup' (make-up gain) function.

On the other hand, I may add some fixes to this make-up gain calculation in the future.

Sounds good Aleksey, I guess the biggest difficulty would be maintaining compatibility with previous versions when adding a new make-up gain mode but I agree that it could be improved to make the use of the Dry knob a lot more predictable.

Just an idea...

- Do make-up gain the same way as most other compressors (i.e. currently it's based on an average ? instead of peak level)

- Then the Dry portion of the sound does not go through makeup gain at all and you have a very simple wet / dry control between this compressed output and the original sound.

Just a few thoughts, keep up the awesome work !

Fots


Speaking of other compressors, they use exactly the peak level.  I was trying to use average level.  However, I also add Dry gain into equation - this is probably adding its complexities, because equation is non-linear.

In the worst case, it may be a problem within the equation itself (maybe I've simply overlooked something).  But I won't be able to fix anything in this version due to backwards compatibility requirement.  However, this can be done in the next version branch.


Cool, sounds good :D Thanks for your time and help

Fots

This topic was created before release of the latest product version, and it may contain details irrelevant to this version.  Replying is disabled for this topic.