Voxengo Premium Membership - All Voxengo Plugins For a Fixed One-Time Fee
Forums     Plugins     Impulse Modeler and Deconvolver Deconvolver Problems


Last

Next

Previous

First



Hi Aleksey,

i downloaded your demo of deconvoler and having some problems (questions) with it.  I created a 24bit/48khz testfile with Deconvolver and applied a fade over the whole file later, so it starts with 20hz at 0db and ends with -10db at 20khz because i play it back over my speakers and dont want to destroy them with that much HF gain.  So i played back and recorded the whole thing via a microphone back into the computer, the file is there, everything is right. i trimmed the recorded file so the sound EXACTLY starts and ends where the original testtone started and ended, the files had the sample-identical same length. then i loaded them in deconvolver and processed them (of course in the right order, i tried several times).  But Deconvolver everytime creates a 48byte big file with a impulse that can absolutely not be a room with alot of reverb.  Its a just a 2 samples long waveform it generates. i have no idea what i did wrong, i tried MP and non-MP, i tried the insert silence option and everytime it gives me this wrong result. can you help please? i used deconvolver 1.5 demo.

Thx.


You simply went a wrong way by trimming the file.  You have to leave the leading and trailing silence intact, this is in fact *very* important to leav the trailing silence as you recorded it.

The final length of impulse is calculated simply: RecFile length *minus* TestTone length.  With your approach you get almost zero as a result.


Aha, hmm... but i need to insert at least 10 seconds silence on the testtone cause i need to leave the room when recording the sweep for optimal results.  So what exactly would i do if i have inserted 10 seconds silence on the original testtone file and 1 second at the end to avoid clicks.

1.  Start Recording

2.  Start Playing the file

3. then load them both without cutting into the deconvolver?

but i want to cut the recorded file a bit cause there is noise and artefacts at the beginning?  Can you please help me and explain step by step?

Big Thanks Aleksey!

Good Bye.


Forget it Aleksey, i got it! ;) Sorry for my stupidness again ;)

Don't be afraid of noises and various artifacts.  This generally must not make the final result much inferior.  So, just deconvovle what you have actually recorded.

Later you can edit the resulting impulse file to remove unnecessary leading or trailing silence.


Yes, i noticed that and cutted it after!  Its just that i wanted to make a perfect result, but i noticed it was the wrong way and i can do it after ;) Thanks for making this deconvolver and especially about the high bitrates and the MP function to stop pre-echos! really great.

Thanks and Bye.


Heh...  But what about preamps?  Can I use deconvoller to create preamp impulses?

Yes, you can.  But for these it is suggested to use MP transform option to remove the 'pre-echo'.

Hi Aleksey,

i tried to sample the spring-reverb from a guitar-head.

the result were unfortunately strange sounding artefacts.  Could it be that the spring wasn´t a "time-invariant" system?  By the way, what does that exactly mean?

i also noticed, that with some reverb plug-ins, the same happens:(Waves True Verb, Renaissance Reverb, Cubase Reverb A) Is it impossible to deconvolve them with the deconvolver?

the resulting file is empty and/or contains peaks at the end.  With Arboretum and tc works-plugs it worked.

bye, marco


Time-invairant simply means, the system is non-linear and has some distortion level.

Please, make sure you record enough silence after the sinesweep ends.  This is vital for recovering the reverb.  Also, make sure you don't cut the start of the recorded sinesweep.  It's safer to leave some 100ms before the start.

This topic was last updated 180 days ago, and thus it was archived.  Replying is disabled for this topic.

Last

Next

Previous

First