Voxengo Premium Membership - All Voxengo Plugins For a Fixed One-Time Fee
Winter Holidays 2017-2018 Discount
Forums     Plugins     Deft Compressor Deft crashing Wavelab


Last

Next

Previous

First



All other Voxengo plugins that I have are working OK but using Windows 7, 64bit and Wavelab 8.5.3.0 as soon as I load Deft I get a million error messages from Wavelab. "Deft Compressor has caused a problem" or something like that.

I've recently done a clean install of everything and it's all running very nicely except Deft.

The odd thing is, I THINK it may have been working OK before the re-install !?

Any ideas Alexey ?  Do you have Wavelab on win64 to check it ?

Thanks.


Sorry for the issue, I will check it out when I get WaveLab 8.5 license from Steinberg.

Thanks Aleksey.  FYI I tried installing WL on another PC, also 64 bit but windows 10, and got exactly the same problem.

This issue will be fixed in Deft Compressor 1.6.

Hi Alexey.  Thanks for the post & the update.

Unfortunately I'm still seeing problems in Wavelab.

Not sure how well you know WL, and I apologise that my original error report to you was vague.  To clarify & hopefully make it easier to track down :

I only ever use WL and plugins in the WL Audio Montage mode.

I'm editing & mastering 32bit float mixes, done in Cubase, all stereo, onto CD's or mp3s.

There are two ways of using plugins, in WLabs Montage.

The old way : in the "Master Section".

The new way : Effects Tag in the montage window.

I usually work the new way, so when I found the problems using Deft Comp.  I was adding it as an effect, using the Effects Tab in a stereo audio montage.

That problem is still the same.  I get a message warning me to save my work because ..."

"A serious error has occurred inside the plug-in ‘Deft Compressor’.

WaveLab could control it, but it would be best to save your work and restart WaveLab."

Tonight I tried the new version of Deft using WLabs "old way" . the Master section.

It sort of works in there, but there is something odd going on.

Stereo Montage up and running.

Insert HarmoniEq into Master section FX slot 1.  Plays fine.

Insert Elephant into Master section FX slot 3.  Plays fine.

Insert Span into Master section FX slot 4.  Plays fine.

Insert Deft Comp. into Master section FX slot 2....

Master Section suddenly gets 8 VU meters, and all the plugins after Deft in the signal routing get switched to 8 channels.

I've never seen Elephant with 8 meters before !!

Remove Deft & everything switches back to Stereo, as it should be.

I checked that Defts routing screen looks ok & I think it does (bit confusing in there because I only normally work in stereo.)

Hope it helps.


Thanks for more info.  I think this may be also WaveLab's issue.  Deft Compressor is side-chain capable plugin, and I suspect WaveLab does something wrong with it, because no such issue happens in Cubase or other hosts.

My suggestion is to direct this issue to WaveLab developers and reference this thread.

The problem is that WaveLab uses plugin's default output number of channels which is set to 8.  At the same time it requests 2 input channels.  I do not think this is a correct behavior.  WaveLab should request as many channels as required, not use default number of channels.

Unfortunately, there is a cross-issue with Reaper regarding this.  Reaper uses default channel count in case it does not know how many channels a plugin supports.

VST3 is a broken specification in this respect.  I wholeheartedly suggest to use VST2 Voxengo plugins, because I have no solution to all VST3 discrepancies, and I have to support many hosts, much more than Steinberg developers imagined.


OK, I'm trying to make plugins work both in WaveLab and Reaper, I will release a quick-fix in a couple of days.  But still, this bug unleashed an issue in WaveLab.

The issue with Montage will be also fixed.
This topic was last updated 180 days ago, and thus it was archived.  Replying is disabled for this topic.

Last

Next

Previous

First