Voxengo Premium Membership - All Voxengo Plugins For a Fixed One-Time Fee
Winter Holidays 2017-2018 Discount
Forums     Plugins     Analogflux Suite Using TapeBus for parallel processing


I am attempting to use TapeBus for parallel processing in "Tape Bypass" mode.  I am aware of the latensy issue when using "Tape Bypass", so i used a pink noise generator sent to the wet and dry track.  Using Voxengo Latency Delay on the 'dry' track and monitoring the summed output throuigh Voxengo SPAN, I attempted to align the two tracks.  The two closest latency delay settings (5 & 6 ms) still produce very pronounced notches in the frequency response as shown in the screen shots linked below.

Is there anything I am doing wrong?

Any input would be appreciated.

- jon

5 ms

6 ms


If audio application you are using supports automatic delay compensation you do not have to align audio in such way.

The screen shots are from REAPER 1.821 which definitely has automatic PDC.  I just repeated the experiment with the same result.

Just to clarify, I have "Tape Bypass" selected on the main page of the GUI.  On the secondary page the "Tape On" is selected.

Any ideas why this may be happening?


Could you do the same parallel processing, but without using any latency compensation?  I mean, without using Latency Delay plug-in.

Sorrry for the delay in getting back to this.

Here is the result of the exact same test in SPAN without using Voxengo Latency Delay on the dry track:

SPAN Screen Capture

Definitely still getting comb filtering.

Here are the exact settings on the GUI:

Front Page

Second Page

Please let me know if I can provide any additional information to help solve this?

- Jon


I understand the problem now.

This happens because TapeBus also performs oversampling which does shift frequencies a bit.  So, it is not really possible to use TapeBus in parallel processing.


Thanks for taking the time to help me get to the bottom of that.

- Jon


Aleksey,

would a possible workaround be to put an instance of the plugg, in the same mode but not preforming any processing (controls zero'd out) in the "dry" path line the signals up ??


Yes, that can be a workaround.  Just make sure both instances use the same "Tape" setting.  On the other hand, "Saturate" parameter was added for just that - mix amount of saturated and dry signal.
This topic was last updated 180 days ago, and thus it was archived.  Replying is disabled for this topic.